Thrifty
Posts: 2
Joined: Fri Mar 15, 2019 9:45 pm

Solution to false "Charge Door Open" warning:

Fri Mar 15, 2019 10:11 pm

Recently, the "Charge Door Open" warning came on and remained for a few days despite the door being closed and functioning properly. The problem was found to be that the switch's sensor somehow came loose from behind the charging port. So, if this happens, before taking it to the dealer or ordering a new switch, try this first: Jack up the front of the car, take the wheel off, take off the charging port side of the wheel well cover (no need to totally detach it from the car). Look in the top of the wheel well, dead center, to find where the sensor cable connects to the wiring harness, and gently wiggle the clip loose from the body. Now that it can be pulled down some for easier handling, remove the clip using a flat head screwdriver, and test the sensor. When I had a friend manually squeeze the sensor shut while I was in drive, it was found to be functioning properly. When I disconnected it from the harness, the warning also went away. My sensor cable had actually pulled loose from the back of the charging port with almost no effort. So I think there may be a flaw in the design where it attaches behind the charging port. It was impossible to see how to reconnect it without taking more things apart, so I just permanently removed it, added some dialectric grease to the harness end, and put everything back together. Who needs it anyway. Hope that helps.

Return to “Technical Discussions”